Slow dashboard loading
Resolved
We have identified the issue and seen that the dashboard load performance is back to usual
Posted Nov 06, 2023 - 18:55 CAT
Update
We are continuing to investigate this issue.
Posted Nov 06, 2023 - 18:17 CAT
Investigating
We have discovered that the dashboard is taking longer than usual to load. We are busy investigating this.
Posted Nov 06, 2023 - 18:17 CAT
This incident affected: Dashboard.