Delay in processing Greenlake Subscriptions

Resolved

This incident has been resolved.
Posted May 22, 2025 - 22:42 CAT

Identified

We have identified a delay in processing subscriptions for Greenlake customers. We are investigating this.
Customers do not need to worry, no data will be lost.
Posted May 22, 2025 - 20:43 CAT
This incident affected: Dashboard.