Dashboard loading
Resolved
We found the issue and this has been resolved. There is no lasting impact to customers.
The dashboard should be fully operational now.
Posted Oct 29, 2024 - 17:19 CAT
Investigating
We have seen an issue where some customer dashboards are loading slowly or failing to load. We are currently aware of this problem and are busy investigating
Posted Oct 29, 2024 - 17:10 CAT
This incident affected: Dashboard.