Delayed Test Metrics

Resolved

The cause was a server hardware failure. Our systems automatically replaced this but we needed to manually intervene for smooth recovery.
Posted Nov 06, 2025 - 12:59 CAT

Monitoring

Our systems experienced an issue with our test metric system. Customers might experience delayed data on the dashboard or errors loading graphs.

We have intervened and we are monitoring as it is recovering.
Posted Nov 06, 2025 - 12:11 CAT
This incident affected: Dashboard and Backend (Time series datastore).